Speedo and trip meter both stopped working yoday

A place to discuss matters related to Honda Helix scooters.

Speedo and trip meter both stopped working yoday

Postby miranda » Sun Mar 10, 2019 3:49 pm

Both are back lit when key is turned on

Both show"0"

What should I check?

Connection of speedo cable at front wheel seems tight

Batt is new

Thanks

Jerry
miranda
 
Posts: 148
Joined: Sat Oct 25, 2014 6:40 am
Location: Winter Haven, Florida

Re: Speedo and trip meter both stopped working yoday

Postby zozman » Sun Mar 10, 2019 11:51 pm

Place scooter on centerstand. Raise the front wheel to allow hand spinning of the front wheel. Remove speedo cable from the spedometer gear box assembly. Spin wheel. The blade tip inside assembly gear box should be spinning as front tire spins. If it is not, service speedo gear box assembly.

If the blade tip inside gear box assembly spins with tire rotation, check speedo cable for breakage or dislogement from underside of speedometer instrument cluster.


zoz
87 & 98 Helix
zozman
 
Posts: 479
Joined: Sat Aug 01, 2009 10:59 am

Re: Speedo and trip meter both stopped working yoday

Postby miranda » Mon Mar 11, 2019 6:39 am

ZOZ, thanks man

I'll check as you suggested

Jerry
miranda
 
Posts: 148
Joined: Sat Oct 25, 2014 6:40 am
Location: Winter Haven, Florida

Re: Speedo and trip meter both stopped working yoday

Postby miranda » Mon Mar 11, 2019 1:23 pm

Cable spins at lower end but does not register at dash

So, maybe cable broke or got disconnected at top end

Is it difficult to see where cable connects at top?

This will be my next step

Jerry

PS-Speedo, trip meter and odometer not operating but each is still back lit
miranda
 
Posts: 148
Joined: Sat Oct 25, 2014 6:40 am
Location: Winter Haven, Florida

Re: Speedo and trip meter both stopped working yoday

Postby zozman » Mon Mar 11, 2019 2:39 pm

See if you can pull the speedometer cable out from the bottom. I don't recall if that is possible on the CN250. It is on other scooters.

If you pull out a broken cable, then you'll have to disassemble the handlepipe plastic pieces on the steering bars and remove maintenance cover.

It's similar to replacing the headlight bulb or instrument cluster bulb. You have to get to the underside of the speedo cluster to remove the knurled attachment fastener that holds the cable housing to the cluster. It may have loosened.

Then you can pull the broken cable out...if that's what you have. (manual 20-2)

zoz
87 & 98 Helix
zozman
 
Posts: 479
Joined: Sat Aug 01, 2009 10:59 am

Re: Speedo and trip meter both stopped working yoday

Postby miranda » Mon Mar 11, 2019 5:17 pm

Thanks again ZOZ. I'll try to pull out (downward). Might have just come unscrewed from speedo unit. '01 has only 6K miles.

If cable is broken, where can I get a replacement? I've already done some ebay searching and haven't found anything. Prob should buy new and not used?
miranda
 
Posts: 148
Joined: Sat Oct 25, 2014 6:40 am
Location: Winter Haven, Florida

Re: Speedo and trip meter both stopped working yoday

Postby zozman » Mon Mar 11, 2019 9:34 pm

CABLE (INNER)
44831-KS4-000
$5.22


zoz
87 & 98 Helix
zozman
 
Posts: 479
Joined: Sat Aug 01, 2009 10:59 am

Re: Speedo and trip meter both stopped working yoday

Postby miranda » Tue Mar 12, 2019 11:31 am

Good news.......cable NOT broken........just detached from above

Good tip----Try to pull cable downward to see if it got detached. It will pull completely out if detached.

Three 10 mm bolts hold plastic protection pan and are easy to remove

The difficult part of reattaching at top end was reaching high upward, inserting metal drive and then getting thumb and index finger around knurled bolt and hand tightening (no grip tool I have would reach within narrow space up there)

Thanks so much ZOZ. Without you, I couldn't (wouldn't) have attempted.

Speedo, trip meter and odometer all working well again

Jerry
miranda
 
Posts: 148
Joined: Sat Oct 25, 2014 6:40 am
Location: Winter Haven, Florida


Return to Honda Helix

Who is online

Users browsing this forum: No registered users and 0 guests